FAQ

I don’t have a user name and/or password to access this site. Who should I contact?

Usernames and passwords are issued to members of the health and care services directly. If you work in this sector, your organisation is likely to have nominated an individual who is acting as the Lead Respondent for this assessment. To find out more, please contact support, who will be happy to put you in touch with a member of staff who will assist you further.

 

I have forgotten my username and/or password for this site. How can I recover those details?

In the first instance, please use the “Lost Password” link found underneath the login form. If you are unable to regain access to the site, please get in touch with support.

 

I am receiving security warnings when accessing this site. What should I do?

In some circumstances depending on your network configuration and/or device setup, you may see security warnings when accessing this site despite our security precautions.

If your browser is indicating that access to the site is not secure, ensure that your browser is supported by checking here [acc. Link]. If this does not solve your problem, get in touch with support so that we can assist you with troubleshooting access.

If access is being blocked or warnings you receive are not provided by your browser software, it’s likely your network administrator has restricted access to the web in a way that affects your use of this site. Please contact your support provider to resolve this issue.

 

I have problems with displaying some or all of this site. What can I do to display this site properly?

This site has been tested for use with all modern, commonly used browsers. Please ensure that your browser is supported by checking here [acc. Link]. If this does not solve your problem, get in touch with support so that we can assist you with troubleshooting access.

 

Some elements on this site (e.g. buttons and links) don’t seem to work as expected. What can I do improve things?

Some browsers provide configuration options for the handling of different types of website content. Please verify that your browser’s settings are set to ‘Normal‘ or ‘Default’ (individual descriptions can vary). If this does not solve your problem, get in touch with support so that we can assist you with troubleshooting access.

Back to top